WS-FTP Pro 2006 and IE7 : “NEVER!” ?

I have WS-FTP Pro 7.0 on both multiple computers as well as the newly released IE7.

One computer has no troubles. The other gives me this interesting error when I try to start it up:

The only solution is to click ok and then kill the app from task manager.

Luckily, I found this thread in the Ipswitch forums (which also decries a lack of support from WS-FTP) where a user (who is clearly a pit-bull and chose not to give up on finding a solution – thank you Suzy!!!) has managed to find how to fix the problem, which calls for “hiding” an outdated file.

navigate to where your WSFTP is installed e.g.
c:/program files/ipswitch/ws_ftp professional
and rename PSAPI.dll to PSAPI.dll.old and then reboot

It worked. Yay.

  Sign up for my newsletter so you don't miss my conference & Pluralsight course announcements!  

12 thoughts on “WS-FTP Pro 2006 and IE7 : “NEVER!” ?

  1. Unfortunately that didnt work for me. I do access this software via an RDP session though. There are 2 different versions of the psapi.dll. Ipswitch installes version 4 and windows xp SP2 installes version 5. The fix I found to work is this:

    I copied psapi.dll from "C:\WINDOWS\system32" to "C:\Program Files\Ipswitch\WS_FTP Professional", basically replaced .DLL version 4 with version 5 and this now works. Previously it renaming or deleting psapi.dll from "C:\Program Files\Ipswitch\WS_FTP Professional" didnt resolve the issue.

    Hope this works for everyone else.

  2. WHAT A GREAT POST! Thank you so much for taking the time to put this information out for everyone. The renaming of the file worked wonderfully! ( I did not have to reboot either…running WS_FTP with XP PRO)

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.